2017-12-31 52 views
0

심포니에서 심포니/심포니을 필요로하지 나는이 입력 한 모든 번들 하나를 설치하지 않은 :작곡가 내가 다음 줄에 작곡가를 통해 심포니의 마지막 버전을 설치 한 4

composer require symfony/symfony 

을하지만 문제는 내가 다음과 같은 오류로 끝날 것입니다 :

내가 버전 4.0.2를 지정하면 7,858,476,791,291,544,181,253,210

나는이 오류가 적은을 가지고 있지만 문제는 동일하게 유지 :

composer require symfony/symfony v4.0.2 
./composer.json has been updated 
Loading composer repositories with package information 
Updating dependencies (including require-dev) 
Your requirements could not be resolved to an installable set of packages. 

    Problem 1 
    - Installation request for __root__ No version set (parsed as 1.0.0) -> satisfiable by __root__[No version set (parsed as 1.0.0)]. 
    - symfony/symfony v4.0.2 conflicts with __root__[No version set (parsed as 1.0.0)]. 
    - Installation request for symfony/symfony v4.0.2 -> satisfiable by symfony/symfony[v4.0.2]. 


Installation failed, reverting ./composer.json to its original content. 

내 composer.json :

{ 
    "type": "project", 
    "license": "proprietary", 
    "require": { 
     "php": "^7.1.3", 
     "ext-iconv": "*", 
     "sensiolabs/security-checker": "^4.1", 
     "symfony/console": "^4.0", 
     "symfony/flex": "^1.0", 
     "symfony/framework-bundle": "^4.0", 
     "symfony/lts": "^[email protected]", 
     "symfony/yaml": "^4.0" 
    }, 
    "require-dev": { 
     "symfony/dotenv": "^4.0", 
     "symfony/thanks": "^1.0" 
    }, 
    "config": { 
     "preferred-install": { 
      "*": "dist" 
     }, 
     "sort-packages": true 
    }, 
    "autoload": { 
     "psr-4": { 
      "App\\": "src/" 
     } 
    }, 
    "autoload-dev": { 
     "psr-4": { 
      "App\\Tests\\": "tests/" 
     } 
    }, 
    "replace": { 
     "symfony/polyfill-iconv": "*", 
     "symfony/polyfill-php71": "*", 
     "symfony/polyfill-php70": "*", 
     "symfony/polyfill-php56": "*" 
    }, 
    "scripts": { 
     "auto-scripts": { 
      "cache:clear": "symfony-cmd", 
      "assets:install --symlink --relative %PUBLIC_DIR%": "symfony-cmd", 
      "security-checker security:check": "script" 
     }, 
     "post-install-cmd": [ 
      "@auto-scripts" 
     ], 
     "post-update-cmd": [ 
      "@auto-scripts" 
     ] 
    }, 
    "conflict": { 
     "symfony/symfony": "*" 
    }, 
    "extra": { 
     "symfony": { 
      "id": "0133333333333333337ed17ed", 
      "allow-contrib": false 
     } 
    } 
} 

난 아주 혼란 스럽다. 심포니의 문서에서 이것에 관한 많은 정보를 찾을 수 없다. 나는 작곡가와 잘 어울리지 않는다.

+3

'symfony/symfony '를 포함하고있는'composer.json'의'conflict' 섹션은 어떻게됩니까? 이는 명시 적으로 패키지와'symfony/symfony'를 함께 설치하지 않도록합니다. – ccKep

+0

@ccKep 참으로 나는 뭔가를 오해해야합니다. 왜냐하면 의사가 진술 한 내용을 따르기 때문입니다. –

+0

어느 단계에서 '충돌'섹션이 표시되는지 알려주셨습니까? 링크 한 부분은 제거해서는 안됩니다.'symfony/symfony'가''필요합니다. – ccKep

답변

2

symfony/skeleton 패키지는 Symfony Flex과 함께 사용하도록 설계되었습니다. 그 프로젝트의 요점은 으로 전체 프레임 워크를 사용하여을 피해야하므로 명백히 패키지와 충돌합니다.

symfony/framework-standard-edition에서 프로젝트를 만들거나 전체 프레임 워크를 가져 오거나 Flex의 새로운 기능을 사용하여 필요한 구성 요소 또는 "recipes" 만 가져와야합니다.

+0

InvalidArgumentException을 얻는 동안 짧은 시간 후에'composer create-project symfony/symfony-standard whatever' 명령을 입력 할 때 : 안정성이 안정된 'symfony/symfony-standard'패키지를 찾을 수 없습니다. –

+0

죄송합니다, Github 주소입니다. 원하는 명령은'composer create-project symfony/framework-standard-edition'입니다. – iainn

+2

3.4를 얻게 될 것입니다. 내가 알 수있는 한 4.0 용 표준 에디션은 없다. – Cerad

관련 문제