2017-12-31 17 views
0

gcloud에서 python 앱을 실행하려고하는데 "flask_sqlalchemy import SQLAlchemy에서"파일을 추가 할 때까지 모든 것이 올바르게 작동합니다. 내가 오류 당신은 pip install Flask-SQLAlchemy하지 SQLAlchemy를 설치해야 내가 확장Docker를 사용하여 gcloud에서 Flask 실행 중 오류가 발생했습니다.

from flask import Flask, render_template, flash, redirect, url_for, session, request 
from flask_pymongo import PyMongo 
from wtforms import Form, StringField, TextAreaField, PasswordField, validators 
from functools import wraps 
from flask_sqlalchemy import SQLAlchemy 
from datetime import datetime 

답변

1

을 가져 곳 내 Dockerfile

FROM tiangolo/uwsgi-nginx-flask:python3.6 
MAINTAINER 
COPY ./app /app 
RUN apt-get update 
RUN apt-get --upgrade install -y nmap curl nano dialog net-tools python-pip python3-pip 
python-dev build-essential python-distribute python3 mysql-server 
RUN pip install --upgrade pip flask Flask-PyMongo Flask-WTF SQLAlchemy mysqlclient 

그리고이 부분입니다 "내부 서버 오류"

입니다. 그들은 다르며 Flask-SQLAlchemy에서 가져오고 있습니다.

따라서 귀하의 Dockerfile에서 변경할 :

RUN pip install --upgrade pip flask Flask-PyMongo Flask-WTF Flask-SQLAlchemy mysqlclient 
관련 문제