2012-12-05 2 views
1

qt-designer 4.8.1을 통해 ui를 실행하고 pykdeuic4 (OpenSuse 12.2에서 사용 가능)를 사용하여 해당 py 파일을 생성했지만 pyrcc4에 해당하는 파일을 찾을 수 없습니다. * .qrc 파일을 다운로드하십시오.KDE에서 pyrcc4와 동일

무엇이 해당 도구/명령입니까?

편집 : PyQt는 함께 QtDesigner 사용에 대한 문서의 대부분 (내 플랫폼에 pykdeuic4가) pyuic4/pyuic를 사용하여 나타냅니다 다른 도구 pyrcc4/pyrcc에 관해서는

하지만, 그럴 수 없어 등가물을 찾으십시오.

(pyrcc4)에서 원래 도구를 얻을 수있는 곳이 궁금합니까?

답변

0

글쎄, 여분의 패키지를 설치하는 데 필요한 모든 것이 밝혀졌습니다. python-qt4-utils 기존의 python-qt4의 꼭대기에 있습니다. 자, 유틸리티를 찾았습니다.

2

pyrrc4에 해당하는 PyKDE 전용 도구가 없습니다. KDE python bindings은 PyQt를 기반으로하므로 pyrrc4 만 사용할 수 있습니다.

PyKDE는 ui 파일을 컴파일하기 위해 특수 도구 (pykdeuic4) 만 필요합니다. 분명히 KDE에는 PyQt가 알지 못하는 많은 위젯이 있기 때문입니다.

OpenSuse의 경우 pyrrc가 포함 된 패키지는 python-qt4-utils입니다.