2012-12-17 1 views
0

Android 앱을 개발 중이며 이전 버전을 지원하는 방법에 대해 살펴 보았습니다. (4.0 버전으로 개발 중이고 10 %는 2.2와 50에 있습니다. 2.3에 대한 %). 나는 found the support library을보고, 내가 올바르게 이해했는지 알고 싶었습니다.Android 지원 라이브러리를 사용하여 이전 버전 지원

  1. 버전 2.2에 대한 지원 라이브러리가 제공됩니다.
  2. 정상적인 .jar 파일에서 지원 라이브러리로 전환합니다. 약간의 코드 변경 및 새로운 수입으로 보입니다.
  3. 내 애플은 지금은 지원 라이브러리를 발견했습니다 안드로이드 2.2
+3

이미 작동중인 앱이 이미 작동하고 있다고 알려주시겠습니까? 아니면 포괄적 인 체크리스트를 원하십니까? 또는 단순히 예 또는 아니오 답을 원하십니까? –

+0

4.0에서 작동 중입니다. 2.2에서 작동하도록 만드는 가장 쉬운 방법은 무엇입니까? – dutt

답변

2

작업을 내가

1 단계와 2 단계는 괜찮 제대로 일을 이해하면보고 싶어한다. 시작 지점에 따라 단계 3 이전에 API 레벨 8 (Android 2.2)을 지원하도록 android:minSdkVersion을 조정하는 등의 단계가있을 수 있습니다. 그리고 무엇을 사용하고 싶은지에 따라 (예 : ActionBarSherlock이 일관된 작업 표시 줄 패턴을 위해) 추가 단계가 더 많이 필요할 수 있습니다.